`
lethorld
  • 浏览: 6712 次
  • 性别: Icon_minigender_1
  • 来自: 上海
最近访客 更多访客>>
社区版块
存档分类
最新评论

Hangover 这题很简单,当练练手了。

阅读更多
Hangover

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.






Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

#include <stdio.h>
#include <stdlib.h>

int sticknumber(float length);

int main(int argc, char *argv[])
{
	float length;
	scanf("%4f", &length);
	while (length != 0) {
		printf("%d card(s)\n", sticknumber(length));
		scanf("%4f", &length);
	}
}

int sticknumber(float length)
{
	int i = 1;
	float sum = 1.0/(i + 1);
	while (sum < length) {
		sum += 1.0/((++i)+1);
	}
	return i;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics